top of page

CarterFit Group

Public·12 members
Kai Jackson
Kai Jackson

High-gain Pw-dn4210d Driver 22: The Best USB WiFi Adapter for Online Gaming and Video Streaming


Just bought one myself because it's so cheap I figured I might as well take a punt at it. Got monitor mode working by installing the driver in the first link and the following the instruction in the second link for copying over a file.




High-gain Pw-dn4210d Driver 22



I'm specifically needing to use this adapter with bettercap. After digging into the bettercap code though, that application effectively uses "iw dev wlan0 set txpower fixed 30mBm" when setting "wifi.recon on" within in application (this enables capture) and will just fail if it can't set that value. In the case of the RTL8812BU it does seem to fail because the set of iw commands supported by the driver that I have seems limited and I don't believe this is an issue with the chipset itself.


Based on this I think full functionality is possible with some driver modification (or recompiling bettercap to just skip setting the txpower, but really don't know whether or not that'll work or what other effects it might have).


I am using TP-Link Archer T4U(v3 AC1300) as wireless adapter with realtek-rtl88x2bu as the driver. It works fine in monitor mode and packet injection but unable to connect with any access point though the passphrase wasn't wrong. Initially, I installed realtek-rtl88xxau driver for archerT4U adapter but that didn't work then I tried with realtek-rtl88x2bu driver which worked fine in all case accept the wireless connection. After trying a lot I was able to properly configure the adapter with VirtualBox but now I am facing this connectivity issue heavily. I tried many internet blogs which suggested me to use terminal for connection but those also failed when I tried to authenticate with wpa_supplicant.conf file saying "Operation not permitted". But I was doing all these in a root terminal.


I also tried to connect with the access point via another adapter named TP-LINK wn823n(v2 driver: realtek-rtl8192eu) and faced almost the same problem. But with this adapter, I sometimes got wireless connection which died after a short period of time. Sometimes the prompt of entering passphrase comes again & again but lastly failed to connect with the router.


And if you could suggest me the URL of updated driver of realtek-rtl8812bu for kali which would also be appreciable. Now I am using the driver suggested from the 1st blog by Markurian of -Realtek-RTL8812BU-Driver-for-Kali-Linux this URL.


Looks like there is some problem in Virtualbox as I managed to connect to the router with the same wireless adapter configured with the same driver from a kali USB stick. If you want I can share the output of ip_monitor & journalctl -f for the latter case to figure what's the problem.


Actually I bought the tp-link archer t4u v3 suggested from this blog assuming that the adapter will hold realtek-rtl8812AU as its chipset. But unfortunately, the adapter doesn't I think. Different blog suggests different things. Now, I am totally confused about what chipset the adapter belongs, what is its proper driver for kali. Do this chipset this adapter really supports monitor mode & packet injection? Because airmon-ng & iw commands fail to put the adapter in monitor mode saying operation not permitted. But with iwconfig the adapter can be put into monitor mode and work well with airodump-ng though iw dev shows that the adapter is still is managed mode. Again "airgeddon" tells the adapter does not support monitor mode.


I am planning to buy TP-LINK TL-WN822N v5, that comes with a different chipset than above mentioned v3. For Linux Mint this worked:sudo apt-get update && sudo apt-get install git dkms build-essentialgit clone -linux-driver.gitsudo dkms add ./rtl8192eu-linux-driversudo dkms install rtl8192eu/1.0


Thank you for sharing the Linux driver and the methods of installing the Linux driver for TP-Link adapter. Your contributions make the community better! We tagged some threads with ' Linux driver' or 'Linux Driver & Highlighted' , you could view more useful and popular threads with the Linux topic here:


Update: We just have checked this Tp link 725n (150MBPS 802.11n) adapter on Ubuntu OS, and we found, there is no driver required. It starts working when we plug into the computer. Installs driver automatically in the background. I have experienced this and I want to share it with here.


About

Welcome to the group! You can connect with other members, ge...

Members

Group Page: Groups_SingleGroup
bottom of page